react-native + react-reduxの導入の際の注意点

現時点でのreact-native最新バージョンは0.16

このバージョンはBabel6を利用しています.

よって他の依存パッケージ react-reduxなども必然的にbabel6に対応しなくては行けません.

が, react-reduxの最新版はreact-nativeに対応しておらず, 公式では3.1.0を推奨しています. この3.1.0はBabel6に対応していません.

なので正しくjsをビルドできない可能性が出てきます.

よってreact-nativeを最新ではなくbabel5を利用している0.15.0までダウングレードを行い開発を進めていくと良いかと思います.

package.jsonは以下

"dependencies": {
  "react-native": "^0.15.0",
  "react-redux": "^3.1.0",
  "redux": "^3.0.4"
}

react-reduxは最新でもBabel6に対応されていないのでしばらく様子見だと思います.