当ブログをHTTPS化

今更 letsencryptでここをHTTPS化した.

ついでにHTTP2.0への対応も行ってみたのだが, Firefoxではちゃんと認識するが, Chromeでは認識してくれない.

いろいろ調べたらChromeは51でNPNを廃止してALPNを利用するようになったみたいで,

サーバが使っているOpenSSLが1.0.2以降でないとALPNが利用できないために, HTTP2.0と認識してくれないみたいだ.

現状 Ubuntu 14.04ではそうそう1.0.2+が降ってこないと思うのでUbuntu16.04に更新しないといけませんね 😹